ALMinium(Redmine便利カスタマイズ版)が、最近のOS環境でJenkinsを選ぶとインストールが完了しない時の対策(暫定版)

下記記事記載後「2014/5/4」に同様の手順にて作業したところインストールスクリプト序盤で「ruby」のインストールに失敗してるようで、正しくインストールできない状態でした。


mysqld を起動中:                                           [  OK  ]
which: no ruby in (/sbin:/bin:/usr/sbin:/usr/bin)
/tmp/alminium /tmp/alminium
% Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
Dload  Upload   Total   Spent    Left  Speed
0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--
0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--
0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--
113   226  113   226    0     0    217      0  0:00:01  0:00:01 --:--:--   217
--2014-05-04 22:49:39--  http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.3-.tar.gz
ftp.ruby-lang.org をDNSに問いあわせています... 221.186.184.75
ftp.ruby-lang.org|221.186.184.75|:80 に接続しています... 接続しました。
HTTP による接続要求を送信しました、応答を待っています... 404 Not Found
2014-05-04 22:49:39 エラー 404: Not Found。

エラー: 1 行目: 不明なタグ: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
エラー: ファイルが見つかりません (by glob): /root/rpmbuild/RPMS/x86_64/ruby-1.9.3*.rpm
/tmp/alminium
Submodule 'theme/gitmike' (https://github.com/alminium/redmine-theme-gitmike) registered for path 'theme/gitmike'
Submodule 'theme/railsgun' (https://github.com/alminium/redmine_railsgun_theme) registered for path 'theme/railsgun'
Initialized empty Git repository in /tmp/alminium/theme/gitmike/.git/
remote: Counting objects: 34, done.
remote: Compressing objects: 100% (21/21), done.
remote: Total 34 (delta 7), reused 34 (delta 7)
Unpacking objects: 100% (34/34), done.
Submodule path 'theme/gitmike': checked out 'b05dd2caeb86f4011d745ff791f36a7ddcbb1ece'
Initialized empty Git repository in /tmp/alminium/theme/railsgun/.git/
remote: Reusing existing pack: 84, done.
remote: Total 84 (delta 0), reused 0 (delta 0)
Unpacking objects: 100% (84/84), done.
Submodule path 'theme/railsgun': checked out 'c289e3e797fbb9429826414d29e8ef3ff7e39641'
which: no gem1.9 in (/sbin:/bin:/usr/sbin:/usr/bin)
inst-script/gems: line 21: gem: コマンドが見つかりません
inst-script/gems: line 21: gem: コマンドが見つかりません
inst-script/gems: line 21: gem: コマンドが見つかりません
inst-script/gems: line 33: gem: コマンドが見つかりません

 

 

えーと 「ALMinium」(Redmine便利カスタマイズ版)をインストールしようとし、ここ丸1日はまった結果 単純な方法で解決したました。

寝てないのでとりあえず簡単に箇条書きで要点を記載していきます。

  • 「Ubuntu 14.04 LTS」出たぜやっほー ということで、各種サーバのリプレイスの試験を始めた。
  • 試験環境は「VM Ware ESXi 5.5」内に仮想サーバ構築で行った。
  • ALMinium」をUnuntu 14.04 LTS に入れようとしたが、インストール中にパッケージが無くなってるとのことであっさり玉砕。
  • Ubuntu 12.04 LTSもまだいけるよね? ってことでセットアップは完了したが、こちらはjenkinsが入ってない。
  • じゃー ということで 「Centos 6.5」にインストール開始、意味不明なエラーが出たり最後まで行ってもjenkinsのチェックで無限ループになり終わらない。(jenkinsを切れば使える)
  • 上記のパッチを当てても状況改善されず。
    こんな感じの現象「jenkinsのインストールスクリプトが完了しない #120
  • ruby関連をいろいろいじりわけわからなくなり何度も再インストールから再開。
  • ネットを調べるが「Centos 6.4」「Centos 6.5」共に動いてる人は苦労せず動いてる模様。
  • で、どっかのサイトのスクリーンショットにインストール時にOSの種別判定分が表示されてることに気が付く、自分の環境では出ない。
  • なんかの直観で、Centos 6.5で最初に「apt-get update」しない状況で、支持通りにコマンドを打った。
  • OS判定メッセージも出て「RedhatEL」と認識されてる。
  • すんなりインストール完了。(初期のjenkins問題も起きない)

えー 私のこの1日は何だったんでしょうか・・・。

たぶんインストーラーのOSバージョン判定がミスってるんだと思いますが、今日は体力ないので本家の記事探す気なし。

もしかしたら周知の不具合なのかもしれませんが・・・。

とりあえず動きました。

ただ、この後どうするかが問題ですよねアップデートしてない巣の状態ですから。

WS000004

 

 

Eclipse(4.3.1 – Kepler)の日本語化 – (pleiadesの個別インストール)

今回は「Pleiades」の日本語化プラグインを利用し「Eclipse」を日本語化します。

主な手順は

  • 日本語化プラグインファイルをダウンロード。
  • ダウンロードしたファイルを解凍。
  • 「Eclipse」をインストールしたフォルダに必要なフォルダごとコピーする。
  • 「Eclipse」の設定ファイル「eclipse.ini」を編集し、日本語化プラグインを有効化。

 

下記のURLへアクセスします。
http://mergedoc.sourceforge.jp/

今回は「日本語化プラグイン」のみを利用しますので、画面下部の方にある「 Pleiades プラグイン・ダウンロード」より任意のファイルをダウンロードしてください。
(私は「1.4.x」の最新版を選択しました)

Eclipseの日本語化(1)

 

Zipファイルが無事ダウンロードされたら

Eclipseの日本語化(2)

続きを読む «…»

Eclipse(4.3.1 – Kepler)のインストール、設定(Windows 8.x 64bit編)

  • EclipseのZipファイルをダウンロード。
  • ダウンロードしたファイルを解凍。

下記のURLへアクセスします。 http://www.eclipse.org/ 上記メニューの「Download」をクリックします。

CUsersmiDesktopEclipse「4.3.1 - Kepler」の設定「Windows 8.x 64bit編」(1)

 

今回はJava開発環境として使う事を想定しEclipseの種類とし、「Eclipse IDE for Java Developers」を選択します。 各自Windowsの実行ビット数のものを選択してください。 今回は、Windows8.x(64bit)ですので「Eclipse IDE for Java Developers」の「Windows 64 Bit」をクリックします。

CUsersmiDesktopEclipse「4.3.1 - Kepler」の設定「Windows 8.x 64bit編」(2)

続きを読む «…»

Android開発環境構築(Windows 8.x 64bit編) – No.01 はじめに

Androidの開発環境をWindows8.x(64bit)上に構築していきたいと思います。

必要な手順は以下のようになります。
(JDK等既に整ってる方は各項目を飛ばして読んで行って下さい)

  1. JDKの設定(Windows 8.x 64bit編)
  2. Eclipse(4.3.1 – Kepler)のインストール、設定(Windows 8.x 64bit編)
  3. Android SDKの設定
  4. ADTの設定 (Eclipseプラグイン)

 

必要であれば「Eclipse」の日本語化を行えます。

 

JDKの設定(Windows 8.x 64bit編)

Windows 8.x (64bit)用にJDKの設定を行います。
JDKのバージョンは都度変わるので読み替えてください。

手順としては

  • JDKのダウンロード
  • JDKのインストール
  • 環境変数の設定
  • JDKの実行確認

になります。

 

JDKのダウンロード

下記のURLより該当するJDKの最新版をダウンロードします。

http://www.oracle.com/technetwork/jp/java/javase/overview/index.html
(2014/01/12現在 「Java SE Development Kit 7u45」が最新版でした。)

 

「ダウンロード」をクリックします。

JDKの設定「Windows 8.x 64bit編」(5)

 

JDKの最新版は、USサイトからダウンロード可能なようですので、「こちら(USサイト)」をクリックします。

JDKの設定「Windows 8.x 64bit編」(6)

続きを読む «…»